Tuesday, September 8, 2015

Puppet 4 - Examples - Data Types

Puppet 4 has some new functionality. Within the next few blog posts I will give some examples on how to use the new functionality.
The first post covers the new Data Type system.

Friday, May 1, 2015

Puppet Enterprise 3.8 Installation - steps and fixes

The new Puppet Enterprise Version 3.8 is out since a couple of days.
It now supports Puppet 4 officially.
On mailinglist people were telling about installation issues.
This is a summary with fixes for SLES 11 and 12, CentOS 6 and 7, Ubuntu 12.04 and 14.10, Debian 6 and 7.
Seems as if Debian 8 is still to new for PE 3.8.

Sunday, April 26, 2015

Puppet Enterprise on SLES

SLES and OpenSuSE are supported operatingsystems by Puppet.
But I always saw trouble when installing either the Puppet Master or the Agent on SLES.

One needs to take care on locales, paranoid umask, required packages.

Tuesday, September 23, 2014

News from PuppetConf - Puppet 4 server and agent

Puppet is working on new stuff for Puppet 4.x
During PuppetConf they provided information of upcoming changes:

Thursday, September 4, 2014

Summary of Puppet 4 features and deprecations

PuppetLabs maintains a github repo where they manage documents regarding Puppet 4.x changes, deprecations and new features.
This article is a summary on planned and implemented changes.

Thursday, August 7, 2014

OpenNebula Puppet types and providers

When setting up OpenNebula one has to configure many steps.
Since I do not like manual work and due to the reason that we already had the OpenNebula Puppet module available as OpenSource on GitHub, I started working on OpenNebula types and Providers.

You now can declare your OpenNebula infrastructure in Puppet DSL:

Tuesday, July 1, 2014

undefined method parent for nil:NilClass

Funny puppet errors:

err: Could not retrieve catalog from remote server: Error 400 on SERVER: Puppet::Parser::AST::Variable failed with error NoMethodError: undefined method `parent' for nil:NilClass at /etc/puppet/environments/foo/modules/util/manifests/init.pp:23 on node foo.bar.baz

warning: Not using cache on failed catalog
err: Could not retrieve catalog; skipping run

And: it breaks always somewhere different.